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First of all I want to mention, that english is not my mother tongue. So it might very well be, that you spot 
one or another spelling error, faulty grammar or simply bad use of english language - sorry for that!

Second I want to mention, that the information you will find on the next pages is not of scientific nature. 
It’s just what I see and feel in my personal, every day life.

So why should you read on?

Actually I have no idea, probably some of my thoughts might be of help, when you are struggling in creat-
ing 3d models of plants - let it be grass, flowers or trees.

In some cases I recorded video tutorials, so the written part might be very short. I already mentioned that 
english is not my mother tongue - I hope you will be able to understand my mumbling, which I consider to 
be english - I heard from other opinions though. Also the sound quality is not of best quality and some-
times you will hear disturbing noise from around - I guess this is the deal you have to take, in return you´ll 
get this all for free.

So have fun and good luck!

P.S. Some of my models are available online - if you don’t have the time to do your own plants, you might 
consider to visit the website of Greenworks. 
Another option would be to visit the online store of Cornucopia (mostly Vue related) or Turbosquid.

         Jan Walter Schliep

http://www.cornucopia3d.com/brokeredfor.php?artist_store=8
http://www.turbosquid.com/Search/Index.cfm/FuseAction/ProcessSmartSearch/istIncAuthor/janwalter/blAuthorExact/y
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1 Introduction

Most people model single grass blades and scatter 
those on a surface. The result might look okay, but it 
hasn’t much to do with real grass.  
Nature offers a huge amount of different looking 
grass species and very seldom you will find single 
grass blades. In almost all cases grass grows in 
clumps or patches. On the following pages I will try 
to show you different approaches to create convinc-
ing grass - from low poly models to detailed objects.

I will use different tools and applications to create 
the grass. In most cases Xfrog 3.5, Xfrog 4 and 
Cinema4D will be the applications of my choice. 
But I am sure that you easily can transfer the tutori-
als to your favorite software.

Links to references
In case you are in need of some reference pictures - 
perhaps you are living at the north pole or in death 
valley - you might find the following links and 
pictures helpful.

Poaceae (just type into your favorite search 
engine)

Cyperaceae (just type into your favorite search 
engine)

Den virtuella floran (very helpful swedish web-
site)

BioImages (also very useful link)

United States Department of Agriculture

•

•

•

•

•

Above links should give you many references that 
you can use for your work, but actually you just have 
to step out of the door, walk some meters and you 
should find some grass. This might take a little bit 
longer compared to a web search, but its healthier 
;-) 

Some of my personal references
Below you can find some photos and scans I did on 
my own. 

grass growing along the street

The picture above clearly shows the point, 
that grass normally grows in clumps. You´ll 
also notice that there are not only leaves or 
blades, but also stalks (which are cut in this 
case).

On the right you can see the blossom of a 
grass plant and a single leaf. That’s some-
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thing I throw on my scanner very often.

nice example of a grass plant where you can see the stalk, leaves and 
a „young“ blossom.

Apart from the fact that most grass grows in form 
of clumps its also important to keep in mind, that 
there is very often a stalk. Depending on the species 
and of course age the length can vary of course.

I think that’s enough talking for now, time for get-
ting our hands dirty on the first approach to create 
grass for your 3D scenes..
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Actually this approach is so simple, that I almost 
don’t dare to mention it. But I noticed that people 
often forget about the simple things - so here we go 
with something extremely simple. 

Creating grass with help of bill-
boards 
Please take a plane or flat polygon and apply the 
texture of a grass patch - that’s it!

I warned you, this so called tutorial is basic ;-) But 
you can do this in every 3D application and the 
results can be very nice.

Sometimes it’s a good idea to build a cross out of 
two planes for a billboard, so that the grass patch is 
visible from all directions. 
The most time consuming part of this work is to 
create a bitmap with alpha channel, as it can be time 
consuming to cut out the grass plant and isolate it 
from the rest of a photograph. 
So if possible use a uniform background and shoot 

the picture against this background - this will make 
your life much easier.

Now you just have to scatter the billboard over the 
surface and do a render of your scene. Of course 
there’s still place for improvements:

use several different textures and so billboards, 
otherwise you will notice that there are 51834 
copies of the same grass patch

if possible, combine your bitmap texture with 
procedural shaders. In most 3D applications you 
can multiply noise shaders on top of a bitmap. 
When using a 3D noise, every grass patch will 
get a slightly different color

try to combine this technique with other, per-
haps more detailed approaches

You can download a Zip file with the texture that I 
used in the above example. It also contains a Cin-
ema4D R9 scene file: Billboard01

Disadvantages of billboards
even if polygon count is kept low with help of 
this approach, render times can increase signifi-
cantly because of the many alpha planes that 
have to be traced. Often it helps to work with 
shadowmaps instead of raytraced (area) shadows 

when used in animations, this approach can look 
wrong, especially when point of view changes 
dramatically

•

•

•

•

•

2 Billboard	approach

http://www.wallis-eck.de/download/tutorials/2007/grass/files/billboard01.zip
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Step 1: Material settings
During this lesson I will show you, how to model a 
grass patch with Cinema4D R9. I will mainly use 
basic modelling techniques, so you should be able to 
follow with most other software packages too! 
At first we will create a new material for a grass 
blade. You can download the texture right here: 
Grass blade 
When working with Cinema4D its a good idea to 
keep the texture in the same folder as the scene file 
(or in a subfolder called tex). But of course you also 
could work with a direct path, or with the search 
paths (Edit->Preferences->Texture path). 

 

So now go to the Materials Tab and choose File-
>New Material. 
Leftclick the new material icon to bring up the 
attributes in the Attributes Editor. Its also possible 
to doubleclick the material icon to bring up new 
Material Editor. 
Head for the Color channel of the new material and 
specify the path to the grass blade texture. Therefor 
you should leftclick the right icon in the line that 
says texture.

 

Then open the Basic settings and activate the Alpha 
channel. Load the same texture into the slot of the 
Alpha channel. Some of the properties have to be 
adjusted:

activate Premultiplied (because the texture con-
tains a premultiplied alpha channel)

activate Invert

deactivate Soft (we want a sharp and crisp edge)

If you think the texture/material is to blurry (you´ll 
be able to judge this later on, when doing the first 
testrenders), then you might want to change the 
Sampling settings (I prefer to use similar Sampling 
settings in the different material channels).

MIP sampling is very powerful, but sometimes the 
textures look to blurry. You can adjust this by reduc-
ing the Blur Scale value to a number below 0%. 
Or you could use a different sampling method like 
Circle. Circle uses less memory, but as trade of the 
rendertimes might be higher. And especially when 
rendering an animation you should be careful with 
Sampling set to Circle, because this might intro-
duce flickering!

•

•

•

3 Modeling	a	grass	patch	by	hand

http://www.wallis-eck.de/download/tutorials/2007/grass/files/billboard01.zip
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Another point is backlighting or translucency. Grass 
blades are very thin and so light shines through 
them. 
In Cinema4D R9, I often simulate this effect with 
the backlight shader. With a setup that is a little bit 
more sophisticated, you can get even better results:
Activate the Luminance channel and reduce the 
brightness to 0%. Then leftclick the little arrow on 
the right side of texture, choose Fusion out of the 
pop up menu. 
With the Fusion shader you can combine two 
textures or shaders. We want to combine the color 
texture with the Backlight shader. 
Now leftclick Fusion in the Texture slot to bring up 
the attributes of this shader.

Set the Mode to Multiply. Then add the grass blade 
texture to the Base Channel. 
After that, leftclick the little arrow at the right side 
of Blend Channel and choose Effects->Backlight. 
This is the basic setup that we need. The Backlight 
shader is multiplied on top of the color texture. So 
when the leaf is lit from behind, the color texture 
will show up. 
But we still have to adjust the Backlight shader.

Please leftclick the Backlight shader, its settings 
should show up. Change the color from green to 

Okay, now we are done with a basic material for our 
grass blade.

Some additional notes:
You could use the color texture inside the bump-
channel, in most cases this looks better than no 
bump at all. But because normally the grass patches 
will be scattered over a landscape, it might also 
work to use a 3D noise inside the bump channel. 
This helps to hide the fact, that actually all blades 
use the same texture.
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white, or perhaps a bright yellow/orange. Then set 
Illumination to 100% and increase the Shadow 
Intensity to about 80%.

That’s it, we are done with the material. 
You can download the scene file of Step1

Step 2: Modeling a single grass 
blade
Now its time to create the first grass blade. Please 
go to the front view (press F4).

 

Choose the Cubic Spline tool and click into the 
front view (try to „hit“ the center, 0,0,0), then add 
two more points by leftclicking into the viewport. 
Each point should be a little bit higher, so that the 
spline has an height of about 60 units. The spline 
shouldn’t be perfectly straight, think of a grass blade 
and how it bends towards the ground. Rename this 
spline to Path - it will serve as path spline for a 
Sweep Nurbs object.

Then choose a Linear 
Spline tool and add a V-
like spline to the scene 
(rename it to Profile). 

The middle point should be at position 0,0,0, the V 
shape should be flat.

Now add a Sweep Nurbs object to the scene. In the 
objects list, drag the Profile and the Path into the 
Sweep Nurbs. 
The profile spline has to be on first position, the 
path on second position. 
In case that the blade seems twisted, try to turn 
banking off (activate the Sweep Nurbs and go 
for the Object properties in the Attributes tab -> 
uncheck Banking). 
Rename the Sweep Nurbs to Grassblade1.

http://www.wallis-eck.de/download/tutorials/2007/grass/files/step1.zip
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As last step, assign the already created to the Grass 
blade object. You can do this by:

dragging the material icon onto the Grass blade 
object in the viewport

dragging the material icon onto the Grass blade 
object in the objects list

Important:
When going with the standard settings, the texture 
would appear upside down on the Sweep Nurbs -  
by the way, the same is true for the Xfrog4 Branch 
object.

•

•

To change this, you have to enter -1 for Tiles Y. 
To bring up this parameter you have to check the 
Material Tag properties: leftclick the little material 
icon right of the Grass blade object and go for the 
Tag properties in the Attributes manager.

Okay, we made it - we have single grass blade. As 
next step we will duplicate this object and create 
variations.

Download scene file: Step 2

http://www.wallis-eck.de/download/tutorials/2007/grass/files/step2.zip
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Step 3: Creating a clump of grass
Now that we have a single grass blade, we need 
dozens of them. So we have to copy the original 
blade several times and create variations. That’s not 
very thrilling and also not very complicated - its just 
some „dirty“, manual work. 
I will show you some different methods to create 
variations. How many you do and how the final 
patch should look like is up to you.

Copy and Paste
Activate the desired object, choose Edit->Copy, 
then Edit->Paste. You also could use the shortcuts 
„CTRL+C“ and „CTRL+V“. 

Its also possible to 
„CTRL+leftclick“ an 
object, keep the mouse 
button pressed and drag to 
an empty place in the 
objects list. 

You´ll notice how the cursor changes its shape!

Use this method to create several copies. Then use 
the Move-, Rotate- and Scale tool to change the 
transformation of the copies. Its also a good idea to 
switch into the Point tool and change the position 
of the points inside the Path and Profile spline!

Functions->Duplicate
You also could make use of the Duplicate tool 
which was improved a lot with Release 9 of Cin-
ema4D. 
Enter the number of copies you want, the Mode (I 
used Circle, this arranges the copies in a - tataaah-
hh! - circle) and adjust the rest of the parameters. 
When you think you are done, click on Apply and 
watch the result in the viewport. 
And now comes the nice part of the new Duplicate 
tool in C4D R9: when you don’t like the result, 

simply change the values, the copies will be interac-
tively rearranged!

You also could make use of Arrange (Function->Ar-
range) to arrange the blades along a line, circle or 
along a spline. Simply select the objects you want 
to arrange and then choose Function->Arrange and 
enter the values you need.

If you want to scatter the blades a little bit, then use 
Function->Randomize on the desired objects. All 
these tools are interactive, so its easy to play around 
with different values until you are satisfied.

Don’t forget: after duplicating and scattering, you 
also should use the Point tool to change the change 
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the path and profile splines. 
Simply create as many grass blades as you need for 
your purpose. By the way: its not only important to 
change the shape of the single blades, but also to 
use different textures or materials. 
The easiest way would be to copy the existing mate-
rial and simply replace the used bitmaps with a 
different texture of a grass blade. 
If you don’t have a second texture, then you could 
make use of the Filter shader.

Copy the existing material, then go for the Color 
channel of the new material. 
Click on the little arrow at the side of Texture, then 
choose Filter out of the popup menu. The Filter 
shader is added into the Texture slot and the grass 
blade texture should be inside the Filter.

Leftclick the Filter shader to bring up its proper-
ties. You´ll see several sliders, you can use them to 
change the hue, saturation, contrast and some other 
properties. You could turn the green of the original 
texture into a brownish color, so that you also have 
some dry grass in your patch. 
Its really a good idea to play around with the 
materials and shaders, there’s a lot of potential to 
improve the look of your grass patch! 
You could use noise shaders to create more varia-
tions, you could use gradient shaders - there are a 
lot of different possibilities!

When you are satisfied, then you are done ;-) 
Perhaps you only want to create one single object 
out of the separate grass blades. To do so, select 
all your grass blades and rightclick one of them. 
Choose Current State to Object from the popup 
menu. 
Now you should get polygonal copies of your Sweep 
Nurbs grass blades.

With the originals still selected, rightclick and 
choose Group Objects. You then can hide this group, 
but if you want to change something later on, you 
still have the originals.

Now we want to merge the separate objects into 
one patch, but before we have to do some prepara-
tions. If you only used one material you can skip the 
following steps. 
Select a grass blade with a „different“ material and 
activate the Polygon tool. Use the command Selec-
tion->Select All to select all polygons of this blade. 
Now choose Selection->Set Selection - a little red 
triangle should appear on the right side of the ob-
ject. If you leftclick the icon and go for the proper-
ties, then you will be able to assign a name to this 
selection (perhaps the name of the material that you 
used on this object). 
Repeat the above described steps for all objects with 
materials different from the original one. When you 
are done, we can start merging.

Okay, now switch back to the 
Model tool and select all 
separate blades. Then choose: 
Function->Connect. A new 
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object should appear in the objects list. You can 
delete the separate, blades if you want to, then take 
a closer look at the merged object. 
It should show one material icon and several red 
triangles - the selections you defined. Now we just 
have to reapply the missing materials. Unfortunately 
only the selection tags are copied to the new object, 
but not the material tags - we have to do this by 
hand. 
I used three different materials, so what I did was 
this:

CTRL+leftclick on the little material icon

with mouse button still pressed, drag a little bit 
to the right and drop, a copy of the material tag 
should appear

then drag the missing materials from the library 
onto the new icon - it will be replaced by the 
material from the library

repeat these steps until you applied all your 
materials onto the merged object

We are almost done! 
Now we just have to tell the materials, that they 
should be restricted to the according selection. 
So leftclick the icon of a material and go for the 
properties. Enter the name of the according Selec-
tion tag into the field Selection. 
Be careful to use the same name inside the Selec-
tion tag and inside the Selection field of a Material 
tag! 
When you reapplied all materials and restricted 
them to the according selection, then you are done!

You built a little (or big??) grass patch with some 
simple modelling tools.

If you want to download the scene files of this part 
of the tutorial, then please click here: Step 3.

•

•

•

•

http://www.wallis-eck.de/download/tutorials/2007/grass/files/step3.zip
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Xfrog is a powerful tool when it comes to create 
organic structures. This video tutorial will show you, 
how to model a nice clump of grass in just a few 
minutes.

You can download the scene files together with 
textures right here: Xfrog3.5 grass patch 
You can download the video tutorial right here: 
Download video tutorial

For those of you who don’t like to watch TV all the 
time, I will summarize the basic steps needed to 
create a clump of grass with help of Xfrog 3.5.

Basic structure
add a Leaf component

change the shape to something rectangular

use rnd function on RotationX,Y and Z

use Gravitropism 

change shape of profile (Primitive settings)

apply texture

After those steps you should have something that 
looks like a single grass blade, now its time to make 
a patch out of it.

Creating a clump
The Phyllotaxis component will serve as multiplier 
and arrange several copies of our grass blade in a 
clump.

•

•

•

•

•

•

4 Modeling	a	patch	of	grass	with	help	
of	Xfrog	3.5

add a Phyllotaxis component to the scene

in the Hierarchy view, drag the grass blade on 
the Phyllotaxis

adjust the opening angle and the number of 
child objects

adjust the radius

The result of above procedure should be a simple 
patch of grass. Because of the nature of the random 
function inside the Rotation parameters of the Leaf 
component, all leaves should look slightly different.

Now we want to give more volume to the grass 
clump - without adding to many polygons.

Increasing the density
Of course we could just increase the number of 
blades generated by Phyllotaxis, but this would 
result in a higher polygon count. I will try to show a 
different approach:

add a Horn component and adjust the length

change the Primitive type to Area

change the Shape and make use of Rotation

apply bitmap of a small cluster

multiply with a second Phyllotaxis

With help of this technique we easily can increase 
the density of the patch without increasing the 
polygon count to much.

•

•

•

•

•

•

•

•

•

http://www.wallis-eck.de/download/tutorials/2007/grass/files/billboard01.zip
http://www.wallis-eck.de/download/tutorials/2007/grass/movies/XF35_grass/
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You might have worked through the manual grass 
patch tutorial and perhaps you are now thinking „ 
this was not complicated, but there must be a faster 
way“. 
Of course there is a faster way - using tools that are 
designed to solve such tasks!

Xfrog4 is an excellent and very flexible tool, so this 
time I will show you a possibility to create a grass 
patch with the help of Xfrog for Cinema4D. 
First you should download the scene files, the tuto-
rial starts with file Step1 (not very surprising, isn’t 
it?) 
Download Scene files

And this is the link to the video tutorial: 
Xfrog4 Grass Patch

Modeling a single blade
The basic steps that you have to follow inside Xfrog 
4 to create a clump of grass are similar to the ones 
inside Xfrog 3.5

add a Branch object

replace the profile, adjust Thickness and add a 
material

use a Tropism object to bend the blades

Create a cluster
Again the Phyllotaxis will serve us as multiplier for 
the single blades.

•

•

•

add a Phyllotaxis to the scene and adjust angles 
and radius of the Arc spline

drop the Leaf into the Phyllotaxis hierarchy

make use of a Variation object for better results

create copies of the original blade and adjust 
them (profile, path, material for example)

use the Curvature spline to create more auto-
matic variations (noise function)

not only use bitmaps of single grass blades, but 
also textures with small clusters - this helps to 
reduce the polygon count

Some additional notes:
The use of functions can save you a lot of time. 
More detailed tutorials about functions in Xfrog 
will be available in the future, for now just some 
hints.

x can be seen as a placeholder for the control 
curve. So when you enter x in the function field, 
the output would be identical to the control 
curve

i is a shortcut for iteration. It returns an increas-
ing number for each branch. The first branch 
would receive 0, the second branch receives a 
value of 1, the third branch receives 2 and so on

noise returns a pseudo random value between 0 
and 1

•

•

•

•

•

•

•

•

•

5 Modelling	a	patch	of	grass	with	help	
of	Xfrog	4

http://www.wallis-eck.de//download/tutorials/2007/grass/files/patch_XF4.zip
http://www.wallis-eck.de/download/tutorials/2007/grass/movies/XF4_grass/
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u is some sort of gradient or ramp and returns 0 
for the left side of the control curve and 1 at the 
right side of the curve

So as you could see, modeling a patch of grass is no 
big deal when using Xfrog. Especially Xfrog 4 of-
fers some nice functionality like the Variation object 
to simplify the modeling process.

Now it’s time for you to create your own, custom 
grass for your renderings.

Best,

Walli

•



Jan Walter Schliep, Tucherstr. 17d. ¤ 90562 Heroldsberg ¤ tel +49 911 8919867 ¤ www.wallis-eck.de


